Back to overview
Downtime
Website and API unavailable
Feb 23 at 02:15am GMT
Affected services
Admin
Campaigns
API
Resolved
Feb 23 at 03:45am GMT
Infrastructure upgrade complete, all systems back online.
Affected services
Created
Feb 23 at 02:15am GMT
Websites, including admin, campaigns and donor portal and API unavailable due to an infrastructure upgrade.
Affected services