Back to overview
Degraded
Unable to login with SumUp
Apr 30 at 10:47am BST
Affected services
SumUp
Resolved
May 01 at 08:12am BST
SumUp login working again.
Affected services
Created
Apr 30 at 10:47am BST
After choosing to login with SumUp on the Give A Little login page you are presented with a page not found error instead of the SumUp login page.
Affected services