Back to overview
Degraded
Increased errors in SumUp card payments
May 30 at 06:20pm BST
Affected services
SumUp
Resolved
May 30 at 06:38pm BST
SumUp services have returned to normal. You can stay up to date on the status of SumUp services anytime at https://status.sumup.com/.
Affected services
Created
May 30 at 06:20pm BST
See SumUp incident report at https://status.sumup.com/europe/incidents/01HZ588Z3GTAB9E9KSGFBMQ02P
Affected services