Back to overview
Degraded
Intermittent DNS look up failures
Feb 10 at 08:34pm GMT
Affected services
Admin
Campaigns
API
Resolved
Feb 10 at 09:59pm GMT
AWS have resolved the issue.
Affected services
Created
Feb 10 at 08:34pm GMT
Our infrastructure service provider, AWS, is experiencing an ongoing issue with CloudFront (Content Distribution Network) and Route53 (Domain Name Service). This is causing an intermittent issue with the Give A Little websites and API where they cannot be found by browsers or devices.
Affected services