Back to overview
Degraded

SumUp Apple Pay unavailable for webdonations

May 8, 2026 at 3:40pm UTC
Affected services
SumUp

Resolved
May 17, 2026 at 1:51pm UTC

SumUp identified and applied a fix to the issues with Apple Pay on web campaigns.

Created
May 8, 2026 at 3:40pm UTC

Donors attempting to use Apple Pay through SumUp when donating via a web campaign are seeing an "Internal server error" message.

This is being investigated by SumUp.